Immobiliser bypass


#21

yes it’s been confirmed… so long as you believe me that I’ve done it already :slight_smile: it’s no black magic, just reading the wiring diagram for what it is :slight_smile:


#22

So once you do that you can remove the immobilized completely?
For what reason did you do it, engine conversion?


#23

I’m sorry was a bit sceptical about it because on the wiring diagram the wire leads to the fuel pump relay, that’s all. But I did see the note about the other pin being for cars without immobilizer.
How did you go with it @Paulep82?


#24

Yes this wire feeds the fuel pump relay only, however, when the immobilizer is working and the fuel pump wire is pinned to XU7 you will need the special key to start as the immobilizer controls the output. If you pin the fuel pump wire to XU4 the ecu will operate normally with any key


#25

@Mick I’ll get onto this today.
My fuel pump had power and primed without this though… only coils had no power.
Maybe mines not the best example…
I’ll stop throwing up ideas until I can confirm if this worked for me either way.
It does seem right from the diagram though to be fuel pump.


#26

Fuel pump prime is on a different wiring circuit


#27

That was kind of a half truth… Fuel pump should prime regardless as part of the start sequence when you go to key on but the immobilizer will stop the pump signal when you initiate start


#28

Okay results are in.
IMG_0623IMG_0624
So I plugged the plug in to XU4 and XU7 as factory pins. As per pix above.
No spark.
Had fuel pump priming just no spark.
I tried black/white wire into XU4 as it was in xu7 originally, no fuel pump or spark. Black/white wire back to xu7 (factory location) and everything works except spark. I went crazy and started cutting aftermarket alarm out and to get some room pulled out the seat. Under that I found the original immobilizer chip that was missing.
IMG_0625IMG_0620
So I put the chip next to the ignition and turned key. Had spark and engine ran normal. I redone the XU4 to xu7 bridge and had no spark without chip present. as soon as I put the chip next to the key I had spark again.
So to summarise bridging XU4 and xu7 did not work for me (had no spark). Bypassing xu7 and only running XU4 did not work (lost fuel pump). Found chip and worked every time with chip in both bridged and not bridged positions. Without chip car did not spark at all. Don’t know why, but this didn’t work for me.
PS all aftermarket immobilizer and wiring was removed from vehicle as per photos. All wiring returned back to factory.
Any ideas anyone?


#29

Well that’s am interesting one! I wasn’t aware of any factory spark immobilization. It’s certainly not shown anywhere in diagrams :thinking: which ecu are you running? Consequently the cars that I have setup have had the same P39 ecu perhaps there is some one difference in logic on others?

So if you got it running normally with the factory chip what’s the problem you’re facing now?


#30

perhaps the factory immobiliser ecu must be removed in order for the bridged pin to work?
im curious, why did you do this, was it for an engine conversion or did you have the same problem as paulep82, no programmed key?


#31

Conversions only from my end. It send that this is all that is necessary when using the immobilizer ecu with non immobilizer chassis side loom so perhaps you are right in assuming the immobilizer needs to be removed? Worth a try


#32

@LOUFO the issue I originally had is I bought a car with a lost back section of the key with the chip captive.
Now I found it under the seat.
The guy that I bought it from said it was lost and no way to start it. Now I found it, it starts…
But I’m using it for a conversion anyway so I’d like to remove it if possible.
@Mick Iv not tried that. I’ll give it a shot tomorrow
I should have thought of that today.
I was just fed up with removing the alarm so I did the tests for this and gave up on it for today. Lol.
I’ll also take pix of serial numbers of the ecu’s.
I know it’s a 2002 gtvi but that’s it.


#33

yeah it was just a thought I had, if your happy to give it a try it would be greatly appreciated


#34

Ok new test.
Immobilizer unplugged…
No good. Doesn’t have spark with chip or no chip.
Needs to be plugged in for spark.
@LOUFO here are some pix of ecu and immobilizer and body tag for reference.
IMG_0634IMG_0631IMG_0632

I have ECUs from an earlier GTVi and also a YRV. I will try the different ECUs tomorrow when I get a chance and see if it makes any difference.


#35

Does anyone know if the key transponder is programmed into the ecu or the immobiliser?
Example, if you fit a new ecu do you have to reprogram the keys or just pair the immobiliser and ecu?


#36

I believe immobiliser and ecu and immobiliser paired. If you look at my first reply on this thread there is a link to a k3 Terios with info about immobilisers and master keys etc.


#37

ECU and key only, immobiliser is a generic unit. This is from my experience with JB-DET and K3-ve2


#38

Did anyone get any further on this.??

I bought an 02 Cuore without key, got a locksmith to cut me a key thinking it didn’t have an immobiliser(but then I found it)…

So, turn key, gets fuel, gets spark until it fires up for a second then spark disappears and it dies…

Tried switching xu4/xu7 — no more fuel
Still same issue with spark.

Also tried with immobiliser plugged in and unplugged…

Was bought as a cheap run-around so really don’t want to go to the expense of chipped key cut and coded…

Can anyone help?