Airco clutch not engaging

Okay, so after 2 radiator changes and allot of money i still don’t have a working airco.

It did work until I realized that the radiator was leaking. So changed it, still leaking. Got a new radiator and now the magnetic clutch won’t engage.

I’m at the point of just burning the fucker to the ground…

Does anyone know how I could test how and where it fails? I guess it has something to do with the power since the magnetic clutch worked last summer.

I’ve tried reading the electric manual but it is not my cup of thee. A.k.a. I’m really bad at electrics (amongst others)

The top plug had 14v running through it most of the time. It was bouncing up and down. The bottom plug had 0v.

You should be able to bridge the wires at the relay to see if the magnetic clutch will turn on or not. I did this with my old yrv to see if it was working before I got it regassed.
(may have to use a short piece of wire to bridge)

1 Like

Okay thanks for your advice. I took a wire and bypassed everything. Luckily the clutch engaged :partying_face:

When I pulled on the plugs I notices that one snapped off. So I decided to rewire it and now it works :slight_smile:


awesome news mate :+1:

It just that the previous cars I owned were mostly negative wired (so always 12v and connecting negative completed the circuit). Sorry don’t know the English term. Connecting positive wires directly to stuff resulted in some interesting sparks and blown fuses.

  • Electric stuff just isn’t my thing. I know just enough to know not to mess with it to much. So just wanted to know for sure which steps I should take :slight_smile:

I’m glad the air-conditioning is working. Today was 39° which is unheard-of in the Netherlands.

1 Like

Wow, 39 in the Netherlands that’s huge (well I imagine it is) I heard London was getting 40 also.

I think a lot of us have the weak point in electrics also. I only had an idea as I had gone through the same thing within the last year.

1 Like