My A/C idle up doesn't work (g203)

Having an issue with the F2, when I turn the a/c on, it doesn’t bring the idle up
I’ve also noticed it doesn’t have a thermo fan for the condenser and the plug
For that fan has been cut off and the wires are just chilling there.
Does the load from the thermo fan kick the idle up or should I be looking somewhere
Else to resolve this issue?


I don’t honestly know but I would be re-connecting the Thermo fan for the condenser as a start. If there is no fan then get one. It would be making your ac work much harder than it should be without it and way less efficient.

At least that way too you will know if the idle up kicks in also from the extra load.


There should be an idle up valve on the side of the inlet manifold that opens when the a/c is turned on. It basically lets a bit more air into the manifold to bring the idle up. It’s on the drivers side and has two vac lines going to it, might be a brown colour.


Sweet as thanks for the info I will have a look into it after work tomorrow :call_me_hand:

Hi, Does the engine idle higher when cold then drop back to normal as it reaches operating temp?
If so the idle control valve is working which is the first thing you need to check.

I fixed it! It was that part you mentioned, the F2 was missing the idle up for the aircon. Stole it off the g200 hooked it up and it worked thanks for your help bro :muscle:


Sweet, easy fix.

1 Like